
项目一 设计智能水杯 

【项目目标】 

能力目标： 

（1）熟悉 IAR 编译环境。 

（2）掌握仿真调试器驱动的安装方法。 

（3）能够对 PxSEL、PxDIR、PxINP 寄存器进行编程。 

（4）掌握中断使能的步骤。 

（5）能够通过设置定时器 1、3 寄存器用中断方式来实现灯闪烁。 

（6）能够串口发送和接收数据。 

（7）能够使用 CC2530 中的温度传感器采集温度。 

（8）能够使用 ZigBee CC2530 驱动 LCD12864 液晶屏。 

素质目标：通过学习制作智能水杯，学生能够掌握 CC2530 芯片的功能，具备硬件测试 

的能力，提高实际动手能力。 

重点难点： 

（1）了解常见的 ZigBee开发的片上系统。 

（2）熟悉 CC2530片上系统的结构及内部模块功能。 

（3）掌握 IAR 编译软件的安装、编辑与修改。 

（4）掌握通用 I/O 端口的输入输出设置。 

（5）熟悉 PxSEL、PxDIR、PxINP 寄存器的应用。 

（6）了解中断的概念。 

（7）掌握中断屏蔽寄存器、中断标志寄存器的应用。 

（8）了解定时器的概念和基本功能。 

（9）掌握定时器 1、3 寄存器的工作原理和应用。 

（10）熟悉串行通信接口的概念、特点、工作方式。 

（11）掌握串行通信接口寄存器的具体应用。 

（12）掌握用 CC2530 中的温度传感器采集温度的方法。 

（13）掌握用 ZigBee CC2530 驱动 LCD12864 液晶屏的方法。 

【知识纲要】 

CC2530 片上系统、IAR、Smart Flash、PxSEL/PxDIR/PxINP 寄存器、中断屏蔽寄存器、 

中断标志寄存器、定时器 1 和 3 寄存器、串行通信接口、温度传感器、液晶显示。
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【项目分析】 

许多家庭给新出生的宝宝冲奶粉的时候总是掌握不好水的温度，不同牌子的奶粉有不 

同的配比说明，但一般来说都是用  40℃～60℃的温水冲比较好。这个温度不仅有利于加快 

化学反应的速度，促使糖、奶粉等在液体里的溶解，调出比较均匀的溶液，且能保证奶粉 

里的营养物质不被破坏。冲好牛奶后，等温度降到约  37℃时再给宝宝喝。可是爸爸妈妈们 

如何掌握好水温呢？ 

本项目就来设计一款智能水杯，主要针对有婴儿或者老人的家庭不能直观地感知水温 

的问题，结合传感器等技术实现。 

该智能水杯使用温度传感器读取被测温度值，系统采用 CC2530 片上系统，显示部分采 

用 LCD 数码管动态扫描方式显示温度。涉及的知识点主要有 CC2530 片上系统的结构及内 

部模块功能，IAR 编译软件的安装、编辑与修改。为了掌握 CC2530 的使用，为今后的学习 

打好基础，在本项目中我们做了以下几个实验：通过 CC2530 片上系统 I/O 端口控制来实现 

点亮 LED 和按键控制 LED 交替闪烁的操作； 通过 CC2530 的按键控制灯亮灭来实现外设中 

断的操作；通过 CC2530的不同定时器实现传统的点灯操作；通过 CC2530 的串行通信接口 

来测试数据的发送和接收。 最后使用集成在芯片 CC2530 中的温度传感器采集到内部温度传 

感器信息通过串口发送到上位机， 并用 ZigBee CC2530 来驱动 LCD12864液晶屏， 使用 LCD 
液晶显示屏来显示温度的数值。 

任务 1 智能水杯开发平台 

1.1.1  任务描述 

在各种各样制作智能水杯的技术解决方案中，我们需要选择一款合适的开发平台，需 

要有支持 ZigBee 协议栈的硬件应用到 ZigBee 无线传感器网络中，所以该智能开发采用 TI 
公司的 CC2530 无线片上系统。 

1.1.2  任务目标 

（1）了解 ZigBee的概念和特点。 

（2）了解常见的 ZigBee开发的片上系统。 

（3）熟悉 CC2530片上系统的结构及内部模块功能。 

（4）掌握 IAR 编译软件的安装、编辑与修改方法。 

1.1.3  知识学习 

1．ZigBee标准概述 
ZigBee标准是一种新兴的短距离无线网络通信技术，基于 IEEE 802.15.4 协议栈，主要 

面向低速率无线个人区域网（Low Rate Wireless Personal Area Network，LRWPAN） 。它功耗
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低，典型特征是近距离、低功耗、低成本、低传输速率，主要适用于工业监控、远程控制、 

传感网络、家庭监控、安全系统和玩具等领域，目的是满足小型廉价设备的无线联网和控 

制需要。ZigBee 技术采用三种频段：2.4GHz、868MHz 和 915MHz。2.4GHz 频段是全球通 

用频段，868MHz 和  915MHz 是用于美国和欧洲的  ISM 频段，这两个频段的引入避免了 
2.4GHz 附近各种无线通信设备的相互干扰。 

2．常见 ZigBee开发的片上系统 

随着集成电路技术的发展，无线射频芯片厂商采用片上系统（System On Chip，SOC） 

的办法对高频电路进行了大量集成，大大简化了无线射频应用程序的开发。ZigBee 开发板 

（如图 1­1 所示） 旨在开发、 演示各种 ZigBee相关产品应用， 支持 CC2430、 CC2431、 CC2530 
（如图 1­2 所示）等芯片的 ZigBee 开发，但并不局限于此，板上丰富的硬件资源允许用户 

评估、开发、演示其他类型的射频产品等。 

图 1­1    CC2530芯片 图 1­2  基于 CC2530的 ZigBee开发板 

目前比较通用的  ZigBee 基本是  TI 公司的  2.4GHz 的芯片，如  CC2420、CC2430 和 
CC2431，其中 CC2431 有定位功能，CC2430 和 CC2431 用起来都比较方便。最具代表性的 

是 TI公司开发的 2.4GHz IEEE 802.15.4 ZigBee片上系统解决方案 CC2530 无线单片机。TI 
公司提供完整的技术手册、开发文档、工具软件，使得开发者开发无线传感网络应用成为 

可能。TI公司不仅提供实现 ZigBee网络的无线单片机，而且免费提供符合 ZigBee 2007 协 

议规范的协议栈 Z­Stack和较为完整的开发文档。 
3．CC2530 片上系统的结构及内部模块功能 
CC2530 是用于 2.4GHz  IEEE  802.15.4、ZigBee 和 RF4CE 应用的一个真正的片上系统 

（SOC）解决方案。它能够以非常低的总的材料成本建立强大的网络节点。CC2530结合了 

领先的 RF 收发器的优良性能、 业界标准的增强型 8051 CPU、 系统内可编程闪存、 8KB RAM 
和许多其他强大的功能。CC2530  有四种不同的闪存版本：CC2530F32、CC2530F64、 
CC2530F128、CC2530F256，分别具有 32KB、64KB、128KB、256KB 的闪存。CC2530 具 

有不同的运行模式，使得它尤其适应超低功耗要求的系统。运行模式之间的转换时间短进
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一步确保了低能源消耗。 

（1）CC2530 的主要功能特性。 

l  CPU配置：片内集成增强型高速 8051 内核，支持代码预取；256KB  Flash程序存 

储器，支持最新版 ZigBee 2007 Pro协议；8KB 数据存储器；支持硬件调试。 

l 电源供电：支持 2.0～3.6V供电区间，具有 3 种电源管理模式：唤醒模式、睡眠模 

式和中断模式，包括处理器和智能片内外设在内的模块超低功耗。 

l 片内外设：片内集成 5 通道 DMA；MAC 定时器；4个振荡器用于系统时钟和定时 

操作；1 个通用 16 位和 2 个 8位定时器；1 个红外发生电路；32kHz睡眠定时器； 

电源管理与片内温度传感器；8 通道 12 位 A/D 转换器；看门狗等智能外设。高密 

度集成化电路节约成本。 

l 中断：片内中断控制器控制 18个中断源，4 优先级结构。 

l 接口方面： 有 2个可编程串口， 用于主从 SPI或UART操作； I/O控制器控制 21个 I/O 
接口，可以根据需要灵活配置，其中 2个具有 20mA的电流吸收或电流供给能力。 

l 通信方面： 信息帧同步字检测/插入； 数据 CRC­16 校验； 信号强度检测/数字 RSSI； 

硬件支持避免冲突的载波侦听多路存取（CSMA­CA）。 

l 数据加密：片内集成 1 个 AES 协处理器，以支持 IEEE 802.15.4 MAC 层安全所需 

的加密操作。 

l 应用对象： 应用范围包括 2.4GHz IEEE 802.15.4系统、 RF4CE远程控制系统、 ZigBee 
网络、家居自动化、照明系统、工业测控、低功耗 WSN 等领域。 

（2）CC2530 结构分析。 

如图 1­3 所示是 CC2530 的功能模块图。这些模块大致可以分为三类：CPU 和内存相 

关的模块；外设、时钟和电源管理相关的模块，以及无线电相关的模块。 

（3）功能模块介绍。 
1）CPU和内存。 
CC2530 芯片系列中使用的 8051CPU内核是一个单周期的 8051 兼容内核。它有三种不 

同的内存访问总线：单周期访问  SFR、DATA 和主  SRAM。它还包括一个调试接口和一个 

输入扩展中断单元。 

中断控制器：总共提供 18个中断源，分为 6 个中断组，每个与 4 个中断优先级之一相 

关。当设备从活动模式回到空闲模式时，任一中断服务请求就被激发，甚至还可以通过一 

些中断把设备从睡眠模式中唤醒。 
32/64/128/256KB 闪存块：为设备提供了内电路可编程的非易失性程序存储器，映射到 

XDATA存储空间。除了保存程序代码和常量以外，非易失性存储器允许应用程序保存必须 

保留的数据，这样设备重启之后可以使用这些数据。例如可以利用已经保存的网络具体数 

据，就不需要经过完全启动、网络寻找和加入过程。 
2）外设：CC2530包括许多不同的外设，允许应用程序设计者开发先进的应用。 

l 调试接口：执行一个专有的两线串行接口，用于内电路调试。通过这个调试接口， 

可以执行整个闪存存储器的擦除、控制使能哪个振荡器、停止和开始执行用户程



项目一 设计智能水杯  5 

序、执行 8051 内核提供的指令、设置代码断点，以及内核中全部指令的单步调试。 

使用这些技术，可以很好地执行内电路的调试和外部闪存的编程。 

图 1­3    ZigBee功能模块图 

l  I/O 控制器：负责所有通用 I/O 引脚。CPU可以配置外设模块是否控制某个引脚或 

它们是否受软件控制，如果是的话，每个引脚配置为一个输入还是输出，是否连 

接衬垫里的一个上拉或下拉电阻。CPU 中断可以分别在每个引脚上使能。每个连 

接到 I/O 引脚的外设可以在两个不同的 I/O 引脚位置之间选择， 以确保在不同应用 

程序中的灵活性。 

l 五通道  DMA 控制器：系统可以使用一个多功能的五通道  DMA 控制器，使用 
XDATA存储空间访问存储器，因此能够访问所有物理存储器。每个通道（触发器、 

优先级、传输模式、寻址模式、源和目标指针、传输计数）可以用  DMA 描述符 

在存储器的任何地方配置。许多硬件外设（AES 内核、闪存控制器、USART、定 

时器、ADC 接口）通过使用 DMA 控制器在 SFR 或 XREG 地址和闪存、SRAM 
之间进行数据传输，获得高效率操作。 

l 定时器 1：是一个 16 位定时器，具有定时器和 PWM 功能。它有一个可编程的分 

频器，一个  16 位周期值，和  5 个各自可编程的计数器/捕获通道，每个都有一个 
16 位比较值。 每个计数器/捕获通道可以用作一个 PWM 输出或捕获输入信号边沿



无线传感网络技术与应用 6 

的时序。它还可以配置在 IR 产生模式，计算定时器 3周期，输出是 ANDed，定时 

器 3 的输出是用最小的 CPU互动产生调制的消费型 IR 信号。 

l  MAC 定时器（定时器 2）：专门为支持 IEEE 802.15.4 MAC 或软件中其他时槽的协 

议设计。定时器有一个可配置的定时器周期、一个  8 位溢出计数器（可以用于保 

持跟踪已经经过的周期数）、一个 16 位捕获寄存器（用于记录收到/发送一个帧开 

始界定符的精确时间或传输结束的精确时间）和一个 16 位输出比较寄存器（可以 

在具体时间产生不同的选通命令（开始 RX、开始 TX 等）到无线模块） 。 

l 定时器 3 和定时器 4：是 8位定时器，具有定时器、计数器和 PWM 功能。它们有 

一个可编程的分频器，一个 8 位的周期值，一个可编程的计数器通道，具有一个 8 
位的比较值。每个计数器通道可以用作一个 PWM 输出。 

l 睡眠定时器：是一个超低功耗的定时器，计算 32kHz晶振或 32kHz  RC 振荡器的 

周期。睡眠定时器在除了供电模式  3 的所有工作模式下不断运行。这一定时器的 

典型应用是作为实时计数器或作为一个唤醒定时器跳出供电模式 1 或 2。 

l 看门狗：一个内置的看门狗允许 CC2530 在固件挂起的情况下复位自身。当看门狗 

定时器由软件使用时，它必须定期清除，否则当它超时就会复位设备。 
3）无线设备：CC2530 具有一个 IEEE  802.15.4 兼容无线收发器。RF 内核控制模拟无 

线模块。另外，它为 MCU和无线设备之间提供了一个接口，可以发出命令、读取状态、自 

动操作和确定无线设备事件的顺序。无线设备还包括一个数据包过滤和地址识别模块。 

（4）引脚描述。 
CC2530 的引脚排布如图 1­4 所示，对各个引脚的简单描述如表 1­1 所示。 

图 1­4    CC2530的引脚排布
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表 1­1  引脚描述 

引脚名称 描述 

AVDD1  2V～3.6V模拟电源连接 

AVDD2  2V～3.6V模拟电源连接 

AVDD3  2V～3.6V模拟电源连接 

AVDD4  2V～3.6V模拟电源连接 

AVDD5  2V～3.6V模拟电源连接 

AVDD6  2V～3.6V模拟电源连接 

DCOUPL  1.8V数字电源去耦 

DVDD1  2V～3.6V数字电源连接 

DVDD2  2V～3.6V数字电源连接 

GND  接地衬垫必须连接到一个坚固的接地面 

GND  连接到 GND 

P0_0  端口 0.0 

P0_1  端口 0.1 

P0_2  端口 0.2 

P0_3  端口 0.3 

P0_4  端口 0.4 

P0_5  端口 0.5 

P0_6  端口 0.6 

P0_7  端口 0.7 

P1_0  端口 1.0（20mA驱动能力） 

P1_1  端口 1.1（20mA驱动能力） 

P1_2  端口 1.2 

P1_3  端口 1.3 

P1_4  端口 1.4 

P1_5  端口 1.5 

P1_6  端口 1.6 

P1_7  端口 1.7 

P2_0  端口 2.0 

P2_1  端口 2.1 

P2_2  端口 2.2 

P2_3/  端口 2.3/32.768kHz XOSC 

P2_4/  端口 2.4/32.768kHz XOSC 

RF_N  RX期间负 RF输入信号到 LNA 

RF_P  RX期间正 RF输入信号到 LNA
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续表 

引脚名称 描述 

RBIAS  参考电流的外部精密偏置电阻 

RESET_N  复位，活动到低电平 

XOSC_Q1  32 MHz晶振引脚 1或外部时钟输入 

XOSC_Q2  32 MHz晶振引脚 2 

（5）CPU介绍。 
CC2530用一个增强型工业标准的 8位 8051微控制器内核代替了传统的标准 8051微控 

制器，提高 MCU处理能力，以期更好地满足在执行协议栈、网络和应用软件时的要求，增 

强型 8051 的运行时钟为 32MHz，但是使用的依然是标准 8051 指令集。原因在于：第一， 

因为每个时钟周期为一个机器周期，而标准  8051 中是  12 个时钟周期为一个机器周期，这 

可以大大提高机器周期的可利用性；第二，除去被浪费掉的总线状态的方式外，使用标准 
8051 指令集的 CC2530 增强型 8051 内核比标准 8051 内核的性能强出 7 倍，由于指令周期 

在可能的情况下包含了取指令操作所需的时间，故绝大多数单字节指令均可在一个时钟周 

期内完成。除了速度的提高外，CC2530增加内核还有两处改进：增加第二个数据指针；扩 

展了 18 个中断源。CC2530 的 8051 内核的目标码与标准 8051 完全兼容，也可以使用标准 
8051 的汇编器和编译器进行软件开发，所有 CC2530的 8051 指令在目标码和功能上与同类 

的标准 8051产品完全等价。但是，由于 CC2530 的 8051 内核使用不同于标准的指令时钟， 

因此在编程时与标准 8051 的代码略有差异，原因在于外设如定时器的配置等方面不同于标 

准 8051。 
4．相关硬件设计 

（1）主电路设计。由于 CC2530 内部已经建成大量必要的电路，因此其外围只需较少 

的电路即可完成功能实现。 
1）外围电路设计。外围电路设计的原理图如图 1­5 所示，所用参数已标注在图上。 

电容 C11～C17和电感 L2～L4组成了电路中的非平衡变压器以满足 RF输出/输入匹配 

电阻 E1（50Ω）的要求。C21 和 C22 连接在约 32MHz 的晶振电路上；C2 为内部数字稳压 

器的去耦电容，用于电源滤波来提高芯片工作的稳定性；R3 和 R4 为偏置电阻，主要用来 

为 32MHz 的晶振提供合适的工作电流。 
2）电源电路设计。电源电路设计的原理图如图 1­6 所示，所用参数已标注在图上。 

通过此电路可以由外接电源为模块供电。工作电压为 2.6V～3.6V，额定为 3.3V。 
3）串口电路设计。串口电路设计的原理图如图 1­7 所示，所用参数已标注在图上。 

串口电路的设计在于能使模块与 PC 机进行通信。该系统的串口可以通过 RS232 连接 
PC 机，PC 机就通过串口向模块发送控制信息，而模块向 PC 通过串口反馈自己的状态。同 

时， 也可以利用 PC 机通过串口向单片机发送各种数据， 再通过模块的协调器节点向外广播。 
11 针串口电路需要 3.3V供电，与板子上的供电电源匹配。
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图 1­5  外围电路设计 

图 1­6  电源电路设计 

图 1­7  串口电路设计
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（2）PCB 的设计。在画各元器件的封装时尽量选用最小的贴片封装，以减小芯片板的 

面积。进行 PCB 的排版，板子大小长度为 3.6cm×2.6 cm，完成后的 PCB 如图 1­8 所示。 

图 1­8    PCB 

5．IAR 编译软件的安装 

（1）IAR 简介。IAR  Systems 是全球领先的嵌入式系统开发工具和服务供应商。公司 

成立于 1983年，提供的产品和服务涉及嵌入式系统的设计、开发和测试的每一个阶段，包 

括：带有  C/C++编译器和调试器的集成开发环境（IDE） 、实时操作系统和中间件、开发套 

件、硬件仿真器和状态机建模工具。嵌入式 IAR Embedded Workbench是一个非常有效的集 

成开发环境（IDE），它使用户可以充分有效地开发并管理嵌入式应用工程。 

（2） IAR7.51 的安装。 在网上下载 IAR7.51.rar， 解压。 在 ew8051 文件夹中单击 Setup.exe 
进行安装，如图 1­9 所示。在图 1­10 所示的界面中单击 Next 按钮进入图 1­11 所示的界面， 

单击 Accept 按钮进入图  1­12 所示的界面。此时在  IAR7.51 文件夹下双击  key 文件夹下的 
keygen.exe 打开注册码程序，如图 1­13 所示，将图 1­13 中 licence  number 下的数字序列拷 

贝替换如图 1­12 所示的 Licence#后面的数字序列，单击 Next 按钮进入图 1­14 所示的界面。 

将图 1­13中 Licence number 下的序列拷贝到图 1­14中的 Licence key中，单击 Next 按钮进 

入图 1­15 所示的界面。一直单击 Next 按钮直到进入安装进度界面，如图 1­16 所示。安装 

进度满后进入图 1­17 所示界面，单击 Finsh按钮完成安装。
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图 1­9  安装向导 图 1­10  开始界面 

图 1­11  安装协议 图 1­12  用户信息 

图 1­13  输入 key  图 1­14  输入注册码



无线传感网络技术与应用 12 

图 1­15  选择安装路径 图 1­16  安装进度 

图 1­17  确认安装完成 

安装完 IAR7.51 后在“开始”→“所有程序”中打开 IAR，如图 1­18 所示。 

图 1­18  打开软件 IAR 

6．IAR 工程和项目的建立 

（1）新建第一个 IAR 工程。 

现在可以通过桌面上的快捷方式或在“开始”菜单中选择程序来启动  IAR 软件开发环 

境了。

使用  IAR 开发环境应先建立一个新的工作区。在一个工作区中可以创建一个或多个工 

程。用户打开  IAR  Embedded  Workbench 时已经建好了一个工作区，一般会显示如图 1­19 
所示的窗口，可以选择打开最近使用的工作区或向当前工作区添加新的工程。 

选择 File→New→Workspace 命令，现在用户已经建好一个工作区，可以创建新的工程 

并把它放入工作区。
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单击 Project 菜单，选择 Create New Project 命令，如图 1­20 所示。 

图 1­19  打开一个工作区 图 1­20  建立一个新工程 

弹出如图 1­21所示的 “建立新工程” 对话框， 确认 Tool chain栏已经选择 8051， 在 Project 
templates 栏中选择 Empty project，单击 OK 按钮。 

图 1­21  选择工程类型 

根据需要选择工程保存的位置，更改工程名，如 ledtest，单击“保存”按钮，如图 1­22 
所示，这样便建立了一个空的工程，如图 1­23 所示。 

系统产生两个创建配置：调试和发布。在这里我们只使用 Debug即调试。项目名称后的 

星号（*）指示修改还没有保存。选择 File→Save→Workspace 命令保存工作区文件并指明存
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放路径，这里把它放到新建的工程目录下，单击“保存”按钮保存工作区，如图 1­24所示。 

图 1­22  保存工程 图 1­23  工作区窗口中的工程 

图 1­24  保存工作区 

（2）添加文件或新建程序文件。 

选择菜单  Project→Add  File，或者在工作区中右击工程名，在弹出的快捷菜单中选择 
Add File，弹出文件打开对话框，选择需要的文件并单击“打开”按钮。 

如果没有建好的程序文件，也可以选择菜单 File→New→File新建一个空文本文件，向 

文件里添加程序清单 1 中的代码。 

程序清单 1如下： 
#include "ioCC2530.h" 
void Delay(unsigned char n) 
{ 

unsigned char i; 
unsignedint j;
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for(i=0; i<n;i++) 
for(j=1;j;j++); 

} 
void main(void) 
{ 

// CC2530中，I/O口作普通 I/O使用时和每个 I/O端口相关的寄存器有 3个，分别是 PxSEL 
//功能选择寄存器、PxDIR方向寄存器、PxINP输入模式寄存器，其中 x为 0、1、2，这里选 
//择 P1.0上的红色 LED作为 I/O测试 
SLEEP &= ~0x04; 
while(!(SLEEP & 0x40));  //晶体振荡器开启且稳定 
CLKCON &= ~0x47;  //选择 1～32MHz晶体振荡器 
SLEEP |= 0x04; 
P1SEL = 0x00;  //P1.0为普通 I/O口 
P1DIR = 0x01;  //P1.0输出 
while(1) 
{ 

P1_0 = 1; 
Delay(10); 
P1_0 = 0; 
Delay(10) 

} 
} 

选择菜单 File→Save，弹出“另存为”对话框，如图 1­25 所示。 

图 1­25  保存程序文件 

新建一个 source文件夹，将文件名改为 test.c后保存到 source文件夹下。按照前面添加 

文件的方法将 test.c添加到当前工程里，完成的结果如图 1­26所示。 

（3）设置工程选项参数。 

选择 Project→Options 配置与 CC2530 相关的选项。 
1）Target 标签。 

按图 1­27所示配置 Target，选择 Code model 和 Data model，以及其他参数。
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图 1­26  添加程序文件后的工程 

图 1­27  配置 Target 

单击  Derivative  information  栏右边的按钮，选择程序安装位置，如这里是  IAR 
Systems\Embedded Workbench 4.05 Evaluation Version\8051\config\derivatives\chipcon下的文 

件 CC2530.i51。 
2）Data Pointer 标签。 

如图 1­28所示，选择数据指针数 1个，16 位。
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图 1­28  数据指针选择 

3）Stack/Heap标签。 

如图 1­29所示，改变 XDATA 栈大小到 0x1FF。 

图 1­29    Stack/Heap 设置 

单击 Options for node “ledtest”中左边框架内的 Linker 选项，配置相关的选项。 
4）Output 标签。 

选中 Override default 可以在下面的文本框中更改输出文件名。如果要用 C­SPY 进行调 

试，则选中 format 下的 Debug information for C­SPY，如图 1­30 所示。
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图 1­30  输出文件设置 

5）Config标签。 

如图 1­31所示，单击 Linker 栏文本框右边的按钮，选择正确的连接命令文件，如表 1­2 
所示。 

图 1­31  选择连接命令文件 

表 1­2    Code Model 关系表 

Code Model  File 

Near  lnk51ew_cc2530.xcl 

Banked  lnk51ew_cc2530b.xcl 

6）Debugger 标签。 

单击 Options  for  node  “SerialApp”中左边框架内的  Debugger 选项，配置相关的选项。 

在 Setup标签内按图 1­32 所示设置。
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图 1­32  配置调试器 

在Device Description file中选择 CC2530.ddf文件，其位置在程序安装文件夹下，例如 C:\ 
Program Files\IAR Systems\Embedded Workbench 4.05 Evaluation Version\8051\config\derivatives 
\chipcon。 

最后单击 OK 按钮保存设置。 

1.1.4  任务实施 

1．编译、连接、下载 

选择 Project→Make命令或按 F7 键编译和连接工程，如图 1­33所示。 

图 1­33  编译和连接工程
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成功编译工程并且没有错误信息提示后， 按照如图 1­34 所示连接硬件系统 （注 “CC2430 
的 ZigBee模块”部分可以换成网关、扩展板等与仿真器引脚相配的器件） 。 

图 1­34  系统连接图 

选择 IAR 集成开发环境中的菜单 Project→Debug（如图 1­33 所示）或按快捷键 Ctrl+D 
进入调试状态，也可以单击工具栏中的按钮进行程序下载，程序下载完成后  IAR 将自动跳 

转至仿真状态。 
2．IAR 工程的编译和修改 

（1）编译项目。在工作区中选择需要编译的文件，选择 Project→Compile 菜单项，或 

者单击工具栏上的  Compile 按钮，对源程序进行编译。编译过程中的各种信息将显示在屏 

幕下方的 Build信息窗口中，如图 1­35 所示。 

图 1­35  Build信息窗口 

出现错误时，可以按照提示进行相应修改。 

（2）连接项目和调试。进行Debugger和 J­Link/J­Trace设置，如图 1­36和图 1­37所示。 

图 1­36  Debugger设置 

PC机  C51RF­3仿真器  CC2430的 ZigBee模块 
USB接线  10芯下载仿真调试线
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图 1­37  J­Link/J­Trace设置 

选择项目文件夹并右击，选择Make命令，如图 1­38所示。 

图 1­38  选择Make命令连接项目
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弹出如图 1­39 所示的界面，之后进行调试操作，用 J­Link将目标板和计算机连接之后 

单击工具栏中的 Debugger 按钮 ，如图 1­40 和图 1­41所示。 

图 1­39  单击Make后界面 

图 1­40  项目调试 

完成后出现如图 1­42 所示的情形。 

至此，可以进行单步调试，也可以单击 Stop Debugger 按钮在目标板上进行测试。
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图 1­41  项目调试 

图 1­42  调试完成 

1.1.5  任务小结 

本次任务主要学习了使用 IAR 集成开发环境进行 ZigBee开发的基本流程， 以及工程的 

建立、源文件的添加、编译与调试。
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【思考题】 

1．简述 CC2530 各引脚的功能。 
2．建立新的 IAR 工程和项目。 

任务 2 测试智能水杯开发平台 

1.2.1  任务描述 

为了保证智能水杯开发平台的稳定性，在安装调试完 IAR 软件平台后，还需要安装仿 

真调试器的驱动并进行调试，进行 IAR 工程源码的烧写。 

1.2.2  任务目标 

（1）掌握仿真调试器驱动的安装方法。 

（2）掌握 IAR 工程源码的烧写方法。 

（3）掌握程序仿真调试的方法。 

1.2.3  知识学习 

编译好  IAR 工程后就可以调试程序了，需要先连接硬件平台才能进行调试，在计算机 

与 ZigBee硬件系统连接前要在计算机上安装仿真器驱动。 

1.2.4  任务实施 

1．仿真调试器驱动的安装 

安装仿真器前要确认  IAR 已经安装，将仿真器通过开发系统附带的 USB 电缆连接到 PC 
机上， 系统找到新硬件后提示如图 1­43所示的对话框，选择 “从列表或指定位置安装” 单选项， 

单击“下一步”按钮，然后单击“浏览”按钮，选择驱动文件所在路径，如图 1­44所示。 

图 1­43  选择安装驱动的方式


